import re
regex = re.compile(r"((?<=จังหวัด\s)|(?<=จังหวัด)|(?<=จ\.\s)|(?<=จ\.)|(?<=จ\s))([ก-๙]+)|(กรุงเทพ[มหานคร]*)|(กทม)", flags=re.MULTILINE)
test_str = ("ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัดอุบล 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ. อุบล 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัด อุบล 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กรุงเทพ 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กทม 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัดกรุงเทพมหานคร 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กทม. 34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กรุงเทพมหานคร34000\n"
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ อุบล 34000\n"
"ราตรี แสนเล็ก 39หมู่11ซ.บูรพา1 แม่กุ แม่สอด ตาก 63110 0924468731\n"
"กันธิชา. ฤกษจันทร์ 64/10พุนพินมะลวนสุราษฎร์ธานี8413066936166649, พุนพิน")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")