package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-9]{1,2}){1}(\.[0-9]{1,2})?$`)
var str = `20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}