using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/a\/b\/c\/([^\W_]+)(?:_([0-9]+))?\/p1=(.*)\/p2=(.*)\/p3=(.*)\/(.*)";
string input = @"/a/b/c/d_9000/p1=<val1>/p2=<val2>/p3=<val3>/<val4>
/a/b/c/d/p1=<val1>/p2=<val2>/p3=<val3>/<val4>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}