// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) ?\d\/\d?|\.\d{1,}").unwrap();
let string = "1600 1/2 Main St
1600 3/4 Main Street
1600.5 Main St
1600.75 3rd Street";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}