\s*any whitespace character, repeated any number of times
Group entity(?P<entity>([-\w]*\\){2}([-\w]*)) {2}repeats the group contents below exactly 2 times:
*matches any number of characters from the set below:
-the literal - (4510 / 558 / 2D16)
\wany word character
\\the literal \ (9210 / 1348 / 5C16)
*matches any number of characters from the set below:
-the literal - (4510 / 558 / 2D16)
\wany word character
Non-Capturing Group(?:\s*) \s*any whitespace character, repeated any number of times
Group METHOD(?P<METHOD>([A-Z]*\|?)*) *repeats the group contents below any number of times:
*matches any number of characters from the set below:
A-Zone character from A (6510) to Z (9010) (case sensitive)
\|?optionally matches the literal | (12410 / 1748 / 7C16)
\s*any whitespace character, repeated any number of times
Group SCHEME(?P<SCHEME>(?4)) (?4)calls group 4 as a subroutine
\s*any whitespace character, repeated any number of times
(?4)calls group 4 as a subroutine
\s*any whitespace character, repeated any number of times
.*any character (except for line terminators), repeated any number of times
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string