import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\\x[A-Fa-f0-9]{2})+";
final String string = "Ya bani taplak dkk \\xf0\\x9f\\x98\\x84\\xf0\\x9f\\x98\\x84\\xf0\\x9f\\x98\\x84\n"
+ "Setidaknya gw punya jari tengah buat lu, sebelom gw ukur nyali sama bacot lu \\xf0\\x9f\\x98\\x8f\n"
+ "Ari sarua beki mah repeh monyet\\xf0\\x9f\\x98\\x86\\xf0\\x9f\\x98\\x86\n"
+ " Cerita silat lae \\xf0\\x9f\\x98\\x80 semacam Kho Ping Hoo yang dari Indonesia, tapi Liang Ie Shen penulis dari China";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}