// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\\x[A-Fa-f0-9]{2})+").unwrap();
let string = "Ya bani taplak dkk \\xf0\\x9f\\x98\\x84\\xf0\\x9f\\x98\\x84\\xf0\\x9f\\x98\\x84
Setidaknya gw punya jari tengah buat lu, sebelom gw ukur nyali sama bacot lu \\xf0\\x9f\\x98\\x8f
Ari sarua beki mah repeh monyet\\xf0\\x9f\\x98\\x86\\xf0\\x9f\\x98\\x86
Cerita silat lae \\xf0\\x9f\\x98\\x80 semacam Kho Ping Hoo yang dari Indonesia, tapi Liang Ie Shen penulis dari China";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}