package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*b bb[\s\S]*d dd.*$`)
var str = `aaa aa a
bbb bb b
ccc cc c
ddd dd d
eee ee e
fff ff f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}