package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w[-\w]+){2,}`)
var str = `stackoverflow.stack.com/read/this-is-a-very-nice-test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}