import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\.\\d+)+\\b(.*)((?:\\n(?!\\d+\\.\\d).*)*)";
final String string = "1.1 Introduction\n"
+ "There are some sentences in here that I want and I want to do other things with them. There could be hundreds of sentences, who cares.\n"
+ "1.1.1 Something Else\n"
+ "This is where we talk about something else in life.\n"
+ "...\n"
+ "5.1.1 Conclusion";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}