# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+(?:\.\d+)+\b(.*)((?:\n(?!\d+\.\d).*)*)"
test_str = ("1.1 Introduction\n"
"There are some sentences in here that I want and I want to do other things with them. There could be hundreds of sentences, who cares.\n"
"1.1.1 Something Else\n"
"This is where we talk about something else in life.\n"
"...\n"
"5.1.1 Conclusion")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.