re = /^\d+(?:\.\d+)+\b(.*)((?:\n(?!\d+\.\d).*)*)/m
str = '1.1 Introduction
There are some sentences in here that I want and I want to do other things with them. There could be hundreds of sentences, who cares.
1.1.1 Something Else
This is where we talk about something else in life.
...
5.1.1 Conclusion'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end