#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(h[1,3,5]-)?epns(?(1)broker0[1-7])\.eset\.com$"
Local $sString = "epns.eset.com" & @CRLF & _
"" & @CRLF & _
"h1-epnsbroker01.eset.com" & @CRLF & _
"h1-epnsbroker02.eset.com" & @CRLF & _
"h1-epnsbroker03.eset.com" & @CRLF & _
"h1-epnsbroker04.eset.com" & @CRLF & _
"h1-epnsbroker05.eset.com" & @CRLF & _
"h1-epnsbroker06.eset.com" & @CRLF & _
"h1-epnsbroker07.eset.com" & @CRLF & _
"" & @CRLF & _
"h3-epnsbroker01.eset.com" & @CRLF & _
"h3-epnsbroker02.eset.com" & @CRLF & _
"h3-epnsbroker03.eset.com" & @CRLF & _
"h3-epnsbroker04.eset.com" & @CRLF & _
"h3-epnsbroker05.eset.com" & @CRLF & _
"h3-epnsbroker06.eset.com" & @CRLF & _
"h3-epnsbroker07.eset.com" & @CRLF & _
"" & @CRLF & _
"h5-epnsbroker01.eset.com" & @CRLF & _
"h5-epnsbroker02.eset.com" & @CRLF & _
"h5-epnsbroker03.eset.com" & @CRLF & _
"h5-epnsbroker04.eset.com" & @CRLF & _
"h5-epnsbroker05.eset.com" & @CRLF & _
"h5-epnsbroker06.eset.com" & @CRLF & _
"h5-epnsbroker07.eset.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")