re = /\d\d:\d\d%:\d\d(*SKIP)(*FAIL)|(?<!\\)%.*/m
str = 'for 10\\% and %delete-me
for 10\\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me
for 10\\% and 2021-03-09 Tue 04:09%anything %delete-me
for 10 percent%delete-me\''
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result