const regex = new RegExp('(@url)([\\s]=[\\s]*)(?:\\')(.*)(?:\\')(?:;)', 'g')
const str = `@url = 'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer';
@header.add('secret','koutty2222Efdxaaalghteqjkhy')
var @collectionitems = @collectionitem('value1')
var @timeItems = {20221003, 20221004}
@block.loop(@item1 in @collectionitems, @item2 in @timeItems)
@block.end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}