use strict;
my $str = '@url = \'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer\';
@header.add(\'secret\',\'koutty2222Efdxaaalghteqjkhy\')
var @collectionitems = @collectionitem(\'value1\')
var @timeItems = {20221003, 20221004}
@block.loop(@item1 in @collectionitems, @item2 in @timeItems)
@block.end';
my $regex = qr/(@url)([\s]=[\s]*)(?:')(.*)(?:')(?:;)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}