// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(@url)([\s]=[\s]*)(?:')(.*)(?:')(?:;)").unwrap();
let string = "@url = 'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer';
@header.add('secret','koutty2222Efdxaaalghteqjkhy')
var @collectionitems = @collectionitem('value1')
var @timeItems = {20221003, 20221004}
@block.loop(@item1 in @collectionitems, @item2 in @timeItems)
@block.end";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}