re = /^(?=.{1,253}\.?$)(?:(?!-|[^.]+_)[A-Za-z0-9-_]{1,63}(?<!-)(?:\.|$)){2,}$/
str = '_ldap._tcp.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end