using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Measurement\=\""(?<Measurement_0>[^,]*),(?<Measurement_1>[^,]*),(?<Measurement_3>[^,]*),(?<Measurement_4>[^,]*),(?<Measurement_5>[^,]*),(?<Measurement_6>[^,]*),(?<Measurement_7>[^,]*),(?<Measurement_8>[^,]*),(?<Measurement_9>[^,]*),(?<Measurement_10>[^,]*)";
string input = @" 2017-10-18 16:59:30.943, MetaDataFoo=""ValueFoo"", Event_Time=""2017-10-18 16:59:30.943"", Measurement=""45.89502,44.895,44.99505,44.89502,44.89502,45.42877,45.96756,46.09344,46.22437,46.315""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}