package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/([^\\\/]*)\/(.*)\/static\/([^\?]*)`)
var str = `/test/test2/static/?get=parav&test=test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}