Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
href="([^>]+)"
/
g
Input 1
1
New
<a id="link-1" href="/regexp-one">正则文章合集(All In One)</a> <a id="link-2" href="/my-regexp">正则入门教程</a> <a id="link-3" href="/deep-regexp">正则高级教程</a> <a id="link-4" href="/regexp-lookaround">正则环视详解</a> <a id="link-5" href="/php-curl">PHP cURL应用</a>
Substitution
http://www.zjmainstay.cn$1