import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"([^>]+)\"";
final String string = "<a id=\"link-1\" href=\"/regexp-one\">正则文章合集(All In One)</a>\n"
+ "<a id=\"link-2\" href=\"/my-regexp\">正则入门教程</a>\n"
+ "<a id=\"link-3\" href=\"/deep-regexp\">正则高级教程</a>\n"
+ "<a id=\"link-4\" href=\"/regexp-lookaround\">正则环视详解</a>\n"
+ "<a id=\"link-5\" href=\"/php-curl\">PHP cURL应用</a>";
final String subst = "http://www.zjmainstay.cn$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}