import Foundation
let pattern = #"^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
D-EBCB_Cessna_172-K
I-ZARY_Maule_MXT-7
I-ESML_Husky_A1
I-9865_P92_Echo_80CV
I-8982_P92_Echo_100CV
I-BLAE_PA28_Cadet
I-PIDR_PA28_Archer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}