import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s)?://www.)?((flipkart(?:.com)+([^\\s\\.]+[^\\s]*)+[^,.\\s]))";
final String string = "https://www.flipkart.com/sansui-pro-view-102cm-40-inch-full-hd-led-tv-2019/p/itmfg2fyuschpzha?pid=TVSFG2FYGQG8MCWK&affid=extinr&affExtParam1=mbu511967417_34289009_65";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}