# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=(\"|')(.+?)(\"|')"
test_str = ("<a href=\"http://www.sample.ru/docs/price.pdf\" alt=\"цены\">прайс</a>\n"
"<a href=\"https://public.library.ru/menu.pdf\" data-order=\"52\">менюшечка</a>\n"
"<a href=\"https://yandex.ru/web/shtrafy.pdf\">штрафы</a>")
subst = "href=$1docs.google.com/viewer?url=$2$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.