re = /(https?:\/\/\S+)|:[\w+-]+:/m
str = ':smile: :thumbs_up: :+1: :-1:
but NOT if the colons are part of the url, like this URL for example: http://pdf.reuters.com/htmlnews/htmlnews.asp?i=43059c3bf0e37541&u=urn:newsml:reuters.com:20190417:nPn5XHnXBa
I was browsing and found this url :smile: http://pdf.reuters.com/htmlnews/htmlnews.asp?i=43059c3bf0e37541&u=urn:newsml:reuters.com:20190417:nPn5XHnXBa it\'s fantastic :smile::+1: Remember: don\'t forget to upvote!'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result