using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"les-programmes\/[^\/]+\/.*$";
string input = @"/les-programmes/mon-premier-festival-2017
/les-programmes/les-incassables
/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}