# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=(ch-name\">)|(?<=ch-time\">)|(?<=ch-type\">)|(?<=ch-text\">))[\s\S]*?(?=<\/)"
test_str = ("<ul id=\"channelList\">\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span><!-- 1-->\n"
" <span class=\"ch-time\">06:30</span><!-- 2-->\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">NBA TV</span><!-- 3-->\n"
" <span class=\"ch-text\">Sacramento Kings - N.Orleans Pelicans (Basketbol)</span><!-- 4-->\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">07:45</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">TRT Spor</span>\n"
" <span class=\"ch-text\">İlk Baskı (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">11:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">TRT Spor</span>\n"
" <span class=\"ch-text\">Spor Manşet (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">11:05</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">NTV Spor</span>\n"
" <span class=\"ch-text\">Spor Servisi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">12:15</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">TRT Spor</span>\n"
" <span class=\"ch-text\">Set-Maç-Smaç (Voleybol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">13:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Kanal 58</span>\n"
" <span class=\"ch-text\">Sivas Bld. - Pendikspor (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">13:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Kardelen TV</span>\n"
" <span class=\"ch-text\">BB Erzurumspor - Zonguldak (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">14:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Lig Tv</span>\n"
" <span class=\"ch-text\">Futbol Gündemi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">14:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">NTV Spor</span>\n"
" <span class=\"ch-text\">Spor Aktüel (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">20:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Tivibu Spor</span>\n"
" <span class=\"ch-text\">Doğru Taktik (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">20:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">NTV Spor</span>\n"
" <span class=\"ch-text\">Kırmızı Çizgi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">20:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">A Spor</span>\n"
" <span class=\"ch-text\">Beşiktaş SJ - Zielona Gora (Basketbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">20:30</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Eurosport 2</span>\n"
" <span class=\"ch-text\">Lokomotiv Kuban - Valencia Basket (Basketbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">21:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">TRT Spor</span>\n"
" <span class=\"ch-text\">Futbol Keyfi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">21:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Tivibu Spor</span>\n"
" <span class=\"ch-text\">Ters Köşe (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">22:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">TRT Spor</span>\n"
" <span class=\"ch-text\">Devler Sahnesi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">22:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Smartspor 2</span>\n"
" <span class=\"ch-text\">Aris - Banvit (Basketbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">22:15</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">Eurosport 2</span>\n"
" <span class=\"ch-text\">Bilbao Basket - Khimki Moskova (Basketbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">23:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">NTV Spor</span>\n"
" <span class=\"ch-text\">Spor Gecesi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"even\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">23:30</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">TRT Spor</span>\n"
" <span class=\"ch-text\">Spor Gecesi (Futbol)</span>\n"
" </div>\n"
" </li>\n"
" <li class=\"odd\">\n"
" <span class=\"ch-type\">Canlı</span>\n"
" <span class=\"ch-time\">03:00</span>\n"
" <div class=\"ch-desc\">\n"
" <span class=\"ch-name\">NBA TV</span>\n"
" <span class=\"ch-text\">Washington Wizards - Boston Celtics (Basketbol)</span>\n"
" </div>\n"
" </li></ul>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.