$re = '/\(00355\) \d{2}-\d{3}-\d{4}/';
$str = '(00355) 22-333-4444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);