re = /\s*,(?=(?:[^']*'[^']*')*[^']*$)\s*/m
str = '\'Hello world\',dude, Somethings, never, turn and go, bye
\'Hello world\',dude, \'Somethings, never, turn and go\', bye'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end