#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@((?:[\s\S](?!\*\/|@))*)"
Local $sString = "/**" & @CRLF & _
" * Queries the data and returns the value for the given x, y cartesian" & @CRLF & _
" * pair" & @CRLF & _
" * @param x Number The x Co-ordinate being queried" & @CRLF & _
" * @param y Number The y Co-ordinate being queried" & @CRLF & _
" * @return Number The value at the given co-ordinate, or -1 if the " & @CRLF & _
" * co-ordinate is invalid (data will never naturally be less than 0)" & @CRLF & _
" **/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")