using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@((?:[\s\S](?!\*\/|@))*)";
string input = @"/**
* Queries the data and returns the value for the given x, y cartesian
* pair
* @param x Number The x Co-ordinate being queried
* @param y Number The y Co-ordinate being queried
* @return Number The value at the given co-ordinate, or -1 if the
* co-ordinate is invalid (data will never naturally be less than 0)
**/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}