const regex = /@((?:[\s\S](?!\*\/|@))*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@((?:[\\s\\S](?!\\*\\\/|@))*)', 'mg')
const str = `/**
* Queries the data and returns the value for the given x, y cartesian
* pair
* @param x Number The x Co-ordinate being queried
* @param y Number The y Co-ordinate being queried
* @return Number The value at the given co-ordinate, or -1 if the
* co-ordinate is invalid (data will never naturally be less than 0)
**/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}