Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
@((?:[\s\S](?!\*\/|@))*)
/
mg
Input 1
1
New
/** * Queries the data and returns the value for the given x, y cartesian * pair * @param x Number The x Co-ordinate being queried * @param y Number The y Co-ordinate being queried * @return Number The value at the given co-ordinate, or -1 if the * co-ordinate is invalid (data will never naturally be less than 0) **/