re = /@((?:[\s\S](?!\*\/|@))*)/m
str = '/**
         * Queries the data and returns the value for the given x, y cartesian
         * pair
         * @param x Number The x Co-ordinate being queried
         * @param y Number The y Co-ordinate being queried
         * @return Number The value at the given co-ordinate, or -1 if the 
         * co-ordinate is invalid (data will never naturally be less than 0)
         **/'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end