package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*-listText-lastMeasurementTimestamp-deviceTable$`)
var str = `122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}