$re = '/.*-listText-lastMeasurementTimestamp-deviceTable$/';
$str = '122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);