import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?:[^|]*\\|){8}|(?<!^)\\G)[^|\\n]*\\K\\|";
final String string = "1|2|1400|34|A|309|Frank|william|This|is|the|line|here|\n"
+ "1|2|1400|34|A|309|Frank|william|This|is|the|line|here|";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}