$re = '/(?:^(?:[^|]*\|){8}|(?<!^)\G)[^|\n]*\K\|/m';
$str = '1|2|1400|34|A|309|Frank|william|This|is|the|line|here|
1|2|1400|34|A|309|Frank|william|This|is|the|line|here|';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;