using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\n)\d+\n[\d\:\,\s\->]+";
string substitution = @"\n";
string input = @"1
00:00:00,000 --> 00:00:16,700
to use 2 languages.
2
00:00:16,700 --> 00:00:19,600
I was saying that we are going to use 2 languages
3
00:00:19,600 --> 00:00:24,700
...I myself will continue to speak because of time";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}