# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\n)\d+\n[\d\:\,\s\->]+"
test_str = ("1\n"
"00:00:00,000 --> 00:00:16,700\n"
"to use 2 languages.\n\n"
"2\n"
"00:00:16,700 --> 00:00:19,600\n"
"I was saying that we are going to use 2 languages\n\n"
"3\n"
"00:00:19,600 --> 00:00:24,700\n"
"...I myself will continue to speak because of time")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.