const regex = /(?<=<%=).*(?=%>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<%=).*(?=%>)', 'gm')
const str = `<div>
<% if ( \$_createDiv) { %>
<div>Div created!</div>
<% } %>
<h2>
<span><%= \$_var1 %></span>
</h2>
<div><%= markdown.toHTML(\$_var2 ) %></div>
<div><%= \$_var3 +' more text ' + \$_var4 %></div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}