$re = '/^\w+(?=(,? ))(?:\1\w+)+$/m';
$str = 'Valid:
Lorem Ipsum
Lorem, Ipsum
Lorem, Ipsum, Ipsum, Ipsum
Invalid:
Lorem
Lorem, Lorem Lorem
Lorem Lorem, Lorem
Lorem,Lorem,Lorem
Lorem, Lorem,Lorem
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);