re = /([^\s]*\s*)\\rem\{(?:lp|db)\}(\{((?>[^{}]|\n|(?2))*)\})(\s?[^\s]*)/m
str = '
Some text etc word\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps}.
\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps
where more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps from
who more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.}
\\rem{lp}{ more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.
more text {\\ce{O2}} further text {\\ce{H2O}} . some other text the $m = 48$ ({\\ce{O2}}) ps.}
\\subsection{other}
Our bla bla bla'
subst = '$1\\\\textcolor{red}{\\\\underline{<<ReTe>>}}$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result