import Foundation
let pattern = #"(.)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+" \"addressLine1\": \"\","#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\\n""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)