$re = '/^([^-]+)[^\(]+(\([^\)]+\))/';
$str = 'Mais de - valor: R$3.21 - Tipo: (+05)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);