re = /(<.*?>)/
str = '<div id="Content">
<p>1</p>
<h2>1</h2>
<h2>2</h2>
</div>'
subst = '<span>$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result