$re = '/^((?!([\w!#$%&\'*+\-/=?\^_`{|}~]+(\.[\w!#$%&\'*+\-/=?\^_`{|}~]+)*@((([\-\w]+\.)+[a-zA-Z]{2,4})|(([0-9]{1,3}\.){3}[0-9]{1,3})))).)*$/';
$str = 'Dogs welcome. We run a dog sanctuary alongside the house and have a example@example.com 2 acre fenced paddock which can be used for dog walking/training. Events must end by 11pm.You can find some details of the land';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);