import Foundation
let pattern = ##"^((?!([\w!#$%&'*+\-/=?\^_`{|}~]+(\.[\w!#$%&'*+\-/=?\^_`{|}~]+)*@((([\-\w]+\.)+[a-zA-Z]{2,4})|(([0-9]{1,3}\.){3}[0-9]{1,3})))).)*$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Dogs welcome. We run a dog sanctuary alongside the house and have a example@example.com 2 acre fenced paddock which can be used for dog walking/training. Events must end by 11pm.You can find some details of the land"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}