package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((2ª|segunda)|(3ª|terça)|(4ª|quarta)|(5ª|quinta)|(6ª|sexta))(-feira)?$`)
var str = `2ª
3ª
4ª
5ª
6ª
2ª-feira
3ª-feira
4ª-feira
5ª-feira
6ª-feira
segunda
terça
quarta
quinta
sexta
segunda-feira
terça-feira
quarta-feira
quinta-feira
sexta-feira
oitava-feira
segunda-
2ª2ª-feira
-feira
feira
22ª
1ª
7ª
ª
aquartado
sextavado`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}